
<!DOCTYPE html>
<html class="html" lang="en-US"itemscope="itemscope" itemtype="https://schema.org/WebPage">
<head>
<meta name="google-site-verification" content="67P7s0aP-itBIPjunk2a6oNL4VUqapjAcyw0CQsx3x8" />
	<meta charset="UTF-8">
	<link rel="profile" href="http://gmpg.org/xfn/11">

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="viewport" content="width=device-width, initial-scale=1">
	<!-- This site is optimized with the Yoast SEO plugin v16.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Catholic Church in Lafayette Immaculate Heart of Mary -</title>
	<meta name="description" content="Catholic Church in Lafayette Assistant Secretary/Bookkeeper %, % Divine Word Missionaries %, % Welcome to Immaculate Heart of Mary Catholic Church%,Catholic" />
	<link rel="canonical" href="https://ihmchurchlafayette.com/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="website" />
	<meta property="og:title" content="Catholic Church in Lafayette Immaculate Heart of Mary -" />
	<meta property="og:description" content="Catholic Church in Lafayette Assistant Secretary/Bookkeeper %, % Divine Word Missionaries %, % Welcome to Immaculate Heart of Mary Catholic Church%,Catholic" />
	<meta property="og:url" content="https://ihmchurchlafayette.com/" />
	<meta property="og:site_name" content="Immaculate Heart of Mary" />
	<meta property="article:modified_time" content="2021-03-12T17:35:19+00:00" />
	<meta property="og:image" content="https://ihmchurchlafayette.com/wp-content/uploads/2019/06/Immaculate-Heart-of-Mary-Church-1024x586.png" />
	<meta property="og:image:width" content="1024" />
	<meta property="og:image:height" content="586" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Est. reading time" />
	<meta name="twitter:data1" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://ihmchurchlafayette.com/#website","url":"https://ihmchurchlafayette.com/","name":"Immaculate Heart of Mary","description":"Catholic Church in Lafayette","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://ihmchurchlafayette.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://ihmchurchlafayette.com/#primaryimage","inLanguage":"en-US","url":"https://ihmchurchlafayette.com/wp-content/uploads/2019/06/Immaculate-Heart-of-Mary-Church.png","contentUrl":"https://ihmchurchlafayette.com/wp-content/uploads/2019/06/Immaculate-Heart-of-Mary-Church.png","width":1784,"height":1021,"caption":"Immaculate Heart of Mary Church"},{"@type":"WebPage","@id":"https://ihmchurchlafayette.com/#webpage","url":"https://ihmchurchlafayette.com/","name":"Catholic Church in Lafayette Immaculate Heart of Mary -","isPartOf":{"@id":"https://ihmchurchlafayette.com/#website"},"primaryImageOfPage":{"@id":"https://ihmchurchlafayette.com/#primaryimage"},"datePublished":"2019-05-15T20:29:35+00:00","dateModified":"2021-03-12T17:35:19+00:00","description":"Catholic Church in Lafayette Assistant Secretary/Bookkeeper %, % Divine Word Missionaries %, % Welcome to Immaculate Heart of Mary Catholic Church%,Catholic","breadcrumb":{"@id":"https://ihmchurchlafayette.com/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://ihmchurchlafayette.com/"]}]},{"@type":"BreadcrumbList","@id":"https://ihmchurchlafayette.com/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home"}]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Immaculate Heart of Mary &raquo; Feed" href="https://ihmchurchlafayette.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Immaculate Heart of Mary &raquo; Comments Feed" href="https://ihmchurchlafayette.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Immaculate Heart of Mary &raquo; iCal Feed" href="https://ihmchurchlafayette.com/events/?ical=1" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v7.18.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-59550918-56"  type="text/javascript" data-cfasync="false" async></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.18.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-59550918-56';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-59550918-56', {
						forceSSL:true,link_attribution:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( 'pageview' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[2] ) {
												hitObject = {
													'eventAction': 'page_view',
													'page_path' : arguments[2],
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof arguments[1].hitType ) {
											hitObject = arguments[1];
											if ( 'pageview' === hitObject.hitType ) {
												hitObject.eventAction = 'page_view';
											}
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var arg, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
										'page' : 'page_path',
										'location' : 'page_location',
										'title' : 'page_title',
									};
									for ( arg in args ) {
										if ( args.hasOwnProperty(arg) && gaMap.hasOwnProperty(arg) ) {
											hit[gaMap[arg]] = args[arg];
										} else {
											hit[arg] = args[arg];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ihmchurchlafayette.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='contact-form-7-css'  href='https://ihmchurchlafayette.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.4.2' type='text/css' media='all' />
<style id='contact-form-7-inline-css' type='text/css'>
.wpcf7 .wpcf7-recaptcha iframe {margin-bottom: 0;}.wpcf7 .wpcf7-recaptcha[data-align="center"] > div {margin: 0 auto;}.wpcf7 .wpcf7-recaptcha[data-align="right"] > div {margin: 0 0 0 auto;}
</style>
<link rel='stylesheet' id='hovereffect-css'  href='https://ihmchurchlafayette.com/wp-content/plugins/hovereffect/public/css/hovereffect-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://ihmchurchlafayette.com/wp-content/plugins/revslider/public/assets/css/rs6.css?ver=6.3.1' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='siteorigin-panels-front-css'  href='https://ihmchurchlafayette.com/wp-content/plugins/siteorigin-panels/css/front-flex.min.css?ver=2.13.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://ihmchurchlafayette.com/wp-content/themes/oceanwp/assets/fonts/fontawesome/css/all.min.css?ver=5.15.1' type='text/css' media='all' />
<link rel='stylesheet' id='simple-line-icons-css'  href='https://ihmchurchlafayette.com/wp-content/themes/oceanwp/assets/css/third/simple-line-icons.min.css?ver=2.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://ihmchurchlafayette.com/wp-content/themes/oceanwp/assets/css/third/magnific-popup.min.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css'  href='https://ihmchurchlafayette.com/wp-content/themes/oceanwp/assets/css/third/slick.min.css?ver=1.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='oceanwp-style-css'  href='https://ihmchurchlafayette.com/wp-content/themes/oceanwp/assets/css/style.min.css?ver=1.6.7.1557958258' type='text/css' media='all' />
<link rel='stylesheet' id='chld_thm_cfg_child-css'  href='https://ihmchurchlafayette.com/wp-content/themes/oceanwp-child/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='oceanwp-google-font-montserrat-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%2C100i%2C200i%2C300i%2C400i%2C500i%2C600i%2C700i%2C800i%2C900i&#038;subset=latin&#038;display=swap&#038;ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='popup-maker-site-css'  href='//ihmchurchlafayette.com/wp-content/uploads/pum/pum-site-styles.css?generated=1626051462&#038;ver=1.16.2' type='text/css' media='all' />
<link rel='stylesheet' id='nextgen_widgets_style-css'  href='https://ihmchurchlafayette.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/widget/static/widgets.css?ver=3.13' type='text/css' media='all' />
<link rel='stylesheet' id='nextgen_basic_thumbnails_style-css'  href='https://ihmchurchlafayette.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/static/thumbnails/nextgen_basic_thumbnails.css?ver=3.13' type='text/css' media='all' />
<link rel='stylesheet' id='nextgen_basic_slideshow_style-css'  href='https://ihmchurchlafayette.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/static/slideshow/ngg_basic_slideshow.css?ver=3.13' type='text/css' media='all' />
<link rel='stylesheet' id='cf7cf-style-css'  href='https://ihmchurchlafayette.com/wp-content/plugins/cf7-conditional-fields/style.css?ver=2.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='oe-widgets-style-css'  href='https://ihmchurchlafayette.com/wp-content/plugins/ocean-extra/assets/css/widgets.css?ver=5.7.2' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/ihmchurchlafayette.com","hash_tracking":"false","ua":"UA-59550918-56"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=7.18.0' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='accordions_js-js-extra'>
/* <![CDATA[ */
var accordions_ajax = {"accordions_ajaxurl":"https:\/\/ihmchurchlafayette.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/plugins/accordions/assets/frontend/js/scripts.js?ver=5.7.2' id='accordions_js-js'></script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/plugins/hovereffect/public/js/hovereffect-public.js?ver=1.0.0' id='hovereffect-js'></script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/plugins/revslider/public/assets/js/rbtools.min.js?ver=6.3.1' id='tp-tools-js'></script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/plugins/revslider/public/assets/js/rs6.min.js?ver=6.3.1' id='revmin-js'></script>
<link rel="https://api.w.org/" href="https://ihmchurchlafayette.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ihmchurchlafayette.com/wp-json/wp/v2/pages/5" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ihmchurchlafayette.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ihmchurchlafayette.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://ihmchurchlafayette.com/' />
<link rel="alternate" type="application/json+oembed" href="https://ihmchurchlafayette.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fihmchurchlafayette.com%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ihmchurchlafayette.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fihmchurchlafayette.com%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://ihmchurchlafayette.com"><link rel="https://theeventscalendar.com/" href="https://ihmchurchlafayette.com/wp-json/tribe/events/v1/" /><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><meta name="generator" content="Powered by Slider Revolution 6.3.1 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
                <style type="text/css" media="all"
                       id="siteorigin-panels-layouts-head">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</style><link rel="icon" href="https://ihmchurchlafayette.com/wp-content/uploads/2019/05/download-150x150.jpg" sizes="32x32" />
<link rel="icon" href="https://ihmchurchlafayette.com/wp-content/uploads/2019/05/download.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://ihmchurchlafayette.com/wp-content/uploads/2019/05/download.jpg" />
<meta name="msapplication-TileImage" content="https://ihmchurchlafayette.com/wp-content/uploads/2019/05/download.jpg" />
<script type="text/javascript">function setREVStartSize(e){
			//window.requestAnimationFrame(function() {				 
				window.RSIW = window.RSIW===undefined ? window.innerWidth : window.RSIW;	
				window.RSIH = window.RSIH===undefined ? window.innerHeight : window.RSIH;	
				try {								
					var pw = document.getElementById(e.c).parentNode.offsetWidth,
						newh;
					pw = pw===0 || isNaN(pw) ? window.RSIW : pw;
					e.tabw = e.tabw===undefined ? 0 : parseInt(e.tabw);
					e.thumbw = e.thumbw===undefined ? 0 : parseInt(e.thumbw);
					e.tabh = e.tabh===undefined ? 0 : parseInt(e.tabh);
					e.thumbh = e.thumbh===undefined ? 0 : parseInt(e.thumbh);
					e.tabhide = e.tabhide===undefined ? 0 : parseInt(e.tabhide);
					e.thumbhide = e.thumbhide===undefined ? 0 : parseInt(e.thumbhide);
					e.mh = e.mh===undefined || e.mh=="" || e.mh==="auto" ? 0 : parseInt(e.mh,0);		
					if(e.layout==="fullscreen" || e.l==="fullscreen") 						
						newh = Math.max(e.mh,window.RSIH);					
					else{					
						e.gw = Array.isArray(e.gw) ? e.gw : [e.gw];
						for (var i in e.rl) if (e.gw[i]===undefined || e.gw[i]===0) e.gw[i] = e.gw[i-1];					
						e.gh = e.el===undefined || e.el==="" || (Array.isArray(e.el) && e.el.length==0)? e.gh : e.el;
						e.gh = Array.isArray(e.gh) ? e.gh : [e.gh];
						for (var i in e.rl) if (e.gh[i]===undefined || e.gh[i]===0) e.gh[i] = e.gh[i-1];
											
						var nl = new Array(e.rl.length),
							ix = 0,						
							sl;					
						e.tabw = e.tabhide>=pw ? 0 : e.tabw;
						e.thumbw = e.thumbhide>=pw ? 0 : e.thumbw;
						e.tabh = e.tabhide>=pw ? 0 : e.tabh;
						e.thumbh = e.thumbhide>=pw ? 0 : e.thumbh;					
						for (var i in e.rl) nl[i] = e.rl[i]<window.RSIW ? 0 : e.rl[i];
						sl = nl[0];									
						for (var i in nl) if (sl>nl[i] && nl[i]>0) { sl = nl[i]; ix=i;}															
						var m = pw>(e.gw[ix]+e.tabw+e.thumbw) ? 1 : (pw-(e.tabw+e.thumbw)) / (e.gw[ix]);					
						newh =  (e.gh[ix] * m) + (e.tabh + e.thumbh);
					}				
					if(window.rs_init_css===undefined) window.rs_init_css = document.head.appendChild(document.createElement("style"));					
					document.getElementById(e.c).height = newh+"px";
					window.rs_init_css.innerHTML += "#"+e.c+"_wrapper { height: "+newh+"px }";				
				} catch(e){
					console.log("Failure at Presize of Slider:" + e)
				}					   
			//});
		  };</script>
		<style type="text/css" id="wp-custom-css">
			.text-center{text-align:center !important}.mncus-maryform.nwcknn span.wpcf7-form-control.wpcf7-checkbox span.wpcf7-list-item-label{display:none}.form_contact h2.custtl.cntrd{font-size:24px;margin:0}div#optin div#optinForm{width:100%}.section_app{text-align:center;width:90%;margin:0 auto;background:#fff;padding:20px}.section_app_text{line-height:1.3em;padding:10px 0}a{cursor:pointer}div#ocean_facebook-2{width:90%;margin:0 auto}span.topbar-content{font-weight:700}div#optinhidn{display:none}.wpbc_structure_form input{width:100% !important}textarea#details1{width:100%}div#field_1-0 label,select.ahbfield_service,span.ahb_list_service{display:none}div#fbuilder{width:50%;margin:0 auto}#fbuilder .ui-datepicker-inline{max-width:100% !important}.slotsCalendarfieldname1_1{margin:20px 0}		</style>
		<!-- OceanWP CSS -->
<style type="text/css">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</style></head>



<body class="home page-template-default page page-id-5 wp-custom-logo wp-embed-responsive siteorigin-panels siteorigin-panels-before-js siteorigin-panels-home tribe-no-js oceanwp-theme fullscreen-mobile no-header-border default-breakpoint content-full-width content-max-width has-topbar page-with-background-title page-header-disabled">
    
   

	
	<div id="outer-wrap" class="site clr">

		
		<div id="wrap" class="clr">

			

<div id="top-bar-wrap" class="clr">

	<div id="top-bar" class="clr container">

		
		<div id="top-bar-inner" class="clr">

			
    <div id="top-bar-content" class="clr has-content top-bar-left">

        
        
            
                <span class="topbar-content">

                    <a href="tel:3372354618" style="color:#fff"> (337) 235-4618</a> | 818 12TH St., Lafayette La, 70501

                </span>

            
    </div><!-- #top-bar-content -->



<div id="top-bar-social" class="clr top-bar-right">

	<ul class="clr">

		<li class="oceanwp-facebook"><a href="https://www.facebook.com/Immaculate-Heart-of-Mary-Catholic-Church-1209420412553260" title="Facebook" target="_blank"><span class="fab fa-facebook"></span></a></li>
	</ul>

</div><!-- #top-bar-social -->
		</div><!-- #top-bar-inner -->

		
	</div><!-- #top-bar -->

</div><!-- #top-bar-wrap -->


			
<header id="site-header" class="minimal-header effect-one clr" data-height="50" itemscope="itemscope" itemtype="https://schema.org/WPHeader">

	
		
			
			<div id="site-header-inner" class="clr container">

				
				
<link href="https://fonts.googleapis.com/css?family=Geo&display=swap" rel="stylesheet">
<div id="site-logo" class="clr" itemscope itemtype="https://schema.org/Brand">

	
	<div id="site-logo-inner" class="clr">

		<a href="https://ihmchurchlafayette.com/" class="custom-logo-link" rel="home" aria-current="page"><img width="714" height="137" src="https://ihmchurchlafayette.com/wp-content/uploads/2019/05/IMHC-logo.png" class="custom-logo" alt="Immaculate Heart of Mary Catholic Church" srcset="https://ihmchurchlafayette.com/wp-content/uploads/2019/05/IMHC-logo.png 714w, https://ihmchurchlafayette.com/wp-content/uploads/2019/05/IMHC-logo-300x58.png 300w" sizes="(max-width: 714px) 100vw, 714px" /></a>
	</div><!-- #site-logo-inner -->

	
	
</div><!-- #site-logo -->

			<div id="site-navigation-wrap" class="clr">
		
			
			
			<nav id="site-navigation" class="navigation main-navigation clr" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">

				<ul id="menu-main-menu" class="main-menu dropdown-menu sf-menu"><li id="menu-item-991" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-991"><a class="menu-link"><span class="text-wrap">ABOUT <span class="nav-arrow fa fa-angle-down"></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-14" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14"><a href="https://ihmchurchlafayette.com/history/" class="menu-link"><span class="text-wrap">HISTORY</span></a></li>	<li id="menu-item-580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-580"><a href="https://ihmchurchlafayette.com/masses/" class="menu-link"><span class="text-wrap">MASS SCHEDULE</span></a></li>	<li id="menu-item-592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-592"><a href="https://ihmchurchlafayette.com/pastoral-council-members/" class="menu-link"><span class="text-wrap">PASTORAL COUNCIL MEMBERS</span></a></li></ul>
</li><li id="menu-item-15" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-15"><a href="https://ihmchurchlafayette.com/ministries/" class="menu-link"><span class="text-wrap">MINISTRIES <span class="nav-arrow fa fa-angle-down"></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-1237" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1237"><a href="https://ihmchurchlafayette.com/worship-ministries/" class="menu-link"><span class="text-wrap">WORSHIP MINISTRIES</span></a></li>	<li id="menu-item-1239" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1239"><a href="https://ihmchurchlafayette.com/social-fellowship-ministries/" class="menu-link"><span class="text-wrap">SOCIAL FELLOWSHIP MINISTRIES</span></a></li>	<li id="menu-item-1238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1238"><a href="https://ihmchurchlafayette.com/fraternal-organizations-ministries/" class="menu-link"><span class="text-wrap">FRATERNAL ORGANIZATIONS/MINISTRIES</span></a></li>	<li id="menu-item-693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-693"><a href="https://ihmchurchlafayette.com/ministry-organization-leaders/" class="menu-link"><span class="text-wrap">MINISTRY &#038; ORGANIZATION LEADERS</span></a></li></ul>
</li><li id="menu-item-17" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17"><a href="https://ihmchurchlafayette.com/sacraments/" class="menu-link"><span class="text-wrap">SACRAMENTS</span></a></li><li id="menu-item-16" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16"><a href="https://ihmchurchlafayette.com/religious-education/" class="menu-link"><span class="text-wrap">RELIGIOUS EDUCATION</span></a></li><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-18"><a href="https://ihmchurchlafayette.com/parish-services/" class="menu-link"><span class="text-wrap">PARISH SERVICES <span class="nav-arrow fa fa-angle-down"></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-1042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1042"><a href="https://ihmchurchlafayette.com/mass-intentions/" class="menu-link"><span class="text-wrap">MASS INTENTIONS</span></a></li>	<li id="menu-item-1041" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1041"><a href="https://ihmchurchlafayette.com/parishioner-registration/" class="menu-link"><span class="text-wrap">PARISHIONER REGISTRATION</span></a></li>	<li id="menu-item-1038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1038"><a href="https://ihmchurchlafayette.com/burial-planning/" class="menu-link"><span class="text-wrap">BURIAL PLANNING</span></a></li>	<li id="menu-item-1037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1037"><a href="https://ihmchurchlafayette.com/i-am-program/" class="menu-link"><span class="text-wrap">&#8220;I AM&#8221; PROGRAM</span></a></li>	<li id="menu-item-548" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-548"><a href="https://ihmchurchlafayette.com/rental-request/" class="menu-link"><span class="text-wrap">RENTAL REQUEST</span></a></li>	<li id="menu-item-1046" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1046"><a href="https://ihmchurchlafayette.com/credit-union-2/" class="menu-link"><span class="text-wrap">CREDIT UNION</span></a></li>	<li id="menu-item-1039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1039"><a href="https://ihmchurchlafayette.com/certificate-requests/" class="menu-link"><span class="text-wrap">CERTIFICATE REQUESTS</span></a></li>	<li id="menu-item-1040" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1040"><a href="https://ihmchurchlafayette.com/offertory-envelopes/" class="menu-link"><span class="text-wrap">OFFERTORY ENVELOPES</span></a></li>	<li id="menu-item-20" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20"><a href="https://ihmchurchlafayette.com/link/" class="menu-link"><span class="text-wrap">LINKS OF INTEREST</span></a></li></ul>
</li><li id="menu-item-19" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19"><a href="https://ihmchurchlafayette.com/events/" class="menu-link"><span class="text-wrap">CALENDAR</span></a></li><li id="menu-item-1450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1450"><a href="https://ihmchurchlafayette.com/gallery/" class="menu-link"><span class="text-wrap">Gallery</span></a></li><li id="menu-item-677" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-677"><a href="https://ihmchurchlafayette.com/contact-ihm-catholic-church/" class="menu-link"><span class="text-wrap">CONTACT</span></a></li><li id="menu-item-455" class="donate_btn menu-item menu-item-type-custom menu-item-object-custom menu-item-455"><a href="https://ihmchurchlafayette.com/donate/" class="menu-link"><span class="text-wrap">GIVE</span></a></li></ul>
			</nav><!-- #site-navigation -->

			
			
					</div><!-- #site-navigation-wrap -->
		
		
	
				
	<div class="oceanwp-mobile-menu-icon clr mobile-right">

		
		
		
		<a href="#" class="mobile-menu">
							<i class="fa fa-bars"></i>
							<span class="oceanwp-text">Menu</span>

						</a>

		
		
		
	</div><!-- #oceanwp-mobile-menu-navbar -->


			</div><!-- #site-header-inner -->

			
			
		
				
	
</header><!-- #site-header -->

		
				
		
			
				<!-- end Custom Code -->
						
			<main id="main" class="site-main clr" >

				
	
	<div id="content-wrap" class="container clr">

		
		<div id="primary" class="content-area clr">

			
			<div id="content" class="site-content clr">

				
				
<article class="single-page-article clr">

	
<div class="entry clr" itemprop="text">
		<div id="pl-5"  class="panel-layout" ><div id="pg-5-0"  class="panel-grid panel-has-style" ><div class="panel-row-style panel-row-style-for-5-0" ><div id="pgc-5-0-0"  class="panel-grid-cell" ><div id="panel-5-0-0-0" class="so-panel widget widget_rev-slider-widget widget_revslider panel-first-child panel-last-child" data-index="0" >
			<!-- START sliderdemo REVOLUTION SLIDER 6.3.1 --><p class="rs-p-wp-fix"></p>
			<rs-module-wrap id="rev_slider_2_1_wrapper" data-source="gallery" style="background:transparent;padding:0;margin:0px auto;margin-top:0;margin-bottom:0;">
				<rs-module id="rev_slider_2_1" style="" data-version="6.3.1">
					<rs-slides>
						<rs-slide data-key="rs-11" data-title="Slide" data-anim="ei:d;eo:d;s:,d;r:,0;t:crossfade;sl:d,d;">
							<img src="//ihmchurchlafayette.com/wp-content/plugins/revslider/public/assets/assets/dummy.png" title="Home" data-lazyload="//ihmchurchlafayette.com/wp-content/uploads/2019/06/Capture.png" data-parallax="off" class="rev-slidebg" data-no-retina>
<!--
							--><rs-layer
								id="slider-2-slide-11-layer-5" 
								class="tp-shape tp-shapewrapper"
								data-type="shape"
								data-rsp_ch="on"
								data-xy="x:c;xo:8px,8px,-2px,-4px;y:b;yo:49px,49px,2px,30px;"
								data-text="fw:300;a:inherit;"
								data-dim="w:735px,735px,492px,492px;h:79px,79px,118,118px;"
								data-frame_0="tp:600;"
								data-frame_1="tp:600;sp:290;sR:10;"
								data-frame_999="o:0;tp:600;st:w;sp:4000;sR:3700;"
								style="z-index:5;background-color:rgba(206,158,0,0.55);"
							> 
							</rs-layer><!--

							--><rs-layer
								id="slider-2-slide-11-layer-3" 
								data-type="text"
								data-rsp_ch="on"
								data-xy="x:c;xo:3px,3px,1px,1px;y:b;yo:61px,61px,26px,70px;"
								data-text="s:40,40,30,30;l:50,50,40,40;a:inherit;"
								data-frame_0="x:-50px;tp:600;"
								data-frame_1="tp:600;st:20;sR:20;"
								data-frame_999="x:50px;o:0;tp:600;st:w;sp:400;sR:3680;"
								style="z-index:6;font-family:Georgia, serif;"
							><span style="text-shadow: 0px 2px 3px #000">A Community
FOLLOWING JESUS</span> 
							</rs-layer><!--
-->						</rs-slide>
						<rs-slide data-key="rs-14" data-title="Slide" data-anim="ei:d,d;eo:d,d;s:0,d,d;r:0,0;t:crossfade,fade,fadethroughtransparent;sl:d,d,d;">
							<img src="//ihmchurchlafayette.com/wp-content/plugins/revslider/public/assets/assets/dummy.png" title="Home" data-lazyload="//ihmchurchlafayette.com/wp-content/uploads/2020/04/Father-Wall.png" data-parallax="off" class="rev-slidebg" data-no-retina>
<!--
							--><rs-layer
								id="slider-2-slide-14-layer-1" 
								data-type="text"
								data-color="#ffffff||#000000||#000000||#000000"
								data-rsp_ch="on"
								data-xy="x:c,l,l,c;xo:0,266px,127px,1px;y:b,t,t,t;yo:106px,284px,284px,419px;"
								data-text="s:40,40,30,25;l:50,60,40,40;a:inherit;"
								data-frame_0="x:-50px;"
								data-frame_1="e:none;"
								data-frame_999="x:50px;o:0;e:none;st:3990;sp:400;sR:3690;"
								style="z-index:9;font-family:Georgia, serif;"
							><span style="text-shadow: 0px 2px 3px #000; color:#fff;">With God 
ALL THNGS ARE POSSIBLE!<br>
<small>Matthew 19:26</small></span> 
							</rs-layer><!--

							--><rs-layer
								id="slider-2-slide-14-layer-3" 
								class="tp-shape tp-shapewrapper"
								data-type="shape"
								data-rsp_ch="on"
								data-xy="x:c;xo:1px,1px,-5px,-4px;y:b;yo:85px,85px,7px,68px;"
								data-text="fw:300;a:inherit;"
								data-dim="w:803px;h:145px;"
								data-frame_1="sp:290;sR:10;"
								data-frame_999="o:0;st:w;sp:4000;sR:3700;"
								style="z-index:8;background-color:rgba(206,158,0,0.55);"
							> 
							</rs-layer><!--
-->						</rs-slide>
						<rs-slide data-key="rs-13" data-title="Slide" data-anim="ei:d,d;eo:d,d;s:,d,d;r:0,0;t:crossfade,fade,fadethroughtransparent;sl:d,d,d;">
							<img src="//ihmchurchlafayette.com/wp-content/plugins/revslider/public/assets/assets/dummy.png" title="Home" data-lazyload="//ihmchurchlafayette.com/wp-content/uploads/2020/04/Catholic-Church-in-Lafayette.png" data-parallax="off" class="rev-slidebg" data-no-retina>
<!--
							--><rs-layer
								id="slider-2-slide-13-layer-1" 
								data-type="text"
								data-rsp_ch="on"
								data-xy="x:c;xo:2px,9px,0,0;y:b,t,t,t;yo:70px,372px,282px,477px;"
								data-text="s:40,50,30,30;l:50,60,40,40;a:inherit;"
								data-frame_0="x:-50px;"
								data-frame_1="e:power0.inOut;st:150;sR:150;"
								data-frame_999="x:50px;o:0;e:none;st:w;sp:400;sR:3550;"
								style="z-index:9;font-family:Georgia, serif;"
							><span style="text-shadow: 0px 2px 3px #000">Find Faith
TRUST IN HIM</span> 
							</rs-layer><!--

							--><rs-layer
								id="slider-2-slide-13-layer-3" 
								class="tp-shape tp-shapewrapper"
								data-type="shape"
								data-rsp_ch="on"
								data-xy="x:c;xo:10px;y:b;yo:55px;"
								data-text="fw:300;a:inherit;"
								data-dim="w:614px;h:85px;"
								data-frame_1="sp:290;sR:10;"
								data-frame_999="o:0;st:w;sp:4000;sR:3700;"
								style="z-index:8;background-color:rgba(206,158,0,0.55);"
							> 
							</rs-layer><!--
-->						</rs-slide>
					</rs-slides>
				</rs-module>
				<script type="text/javascript">
					setREVStartSize({c: 'rev_slider_2_1',rl:[1240,1024,778,480],el:[800,500,400,600],gw:[1900,1240,778,480],gh:[800,500,400,600],type:'standard',justify:'',layout:'fullwidth',mh:"0"});
					var	revapi2,
						tpj;
					function revinit_revslider21() {
					jQuery(function() {
						tpj = jQuery;
						revapi2 = tpj("#rev_slider_2_1");
						if(revapi2==undefined || revapi2.revolution == undefined){
							revslider_showDoubleJqueryError("rev_slider_2_1");
						}else{
							revapi2.revolution({
								sliderLayout:"fullwidth",
								duration:4000,
								visibilityLevels:"1240,1024,778,480",
								gridwidth:"1900,1240,778,480",
								gridheight:"800,500,400,600",
								lazyType:"smart",
								perspective:600,
								perspectiveType:"local",
								editorheight:"800,500,400,600",
								responsiveLevels:"1240,1024,778,480",
								progressBar:{disableProgressBar:true},
								navigation: {
									mouseScrollNavigation:false,
									wheelCallDelay:1000,
									onHoverStop:false,
									touch: {
										touchenabled:true,
										swipe_min_touches:50
									}
								},
								parallax: {
									levels:[2,3,4,5,6,7,12,16,10,50,47,48,49,50,51,55],
									type:"mouse",
									origo:"slidercenter",
									speed:2000
								},
								fallbacks: {
									allowHTML5AutoPlayOnAndroid:true
								},
							});
						}
						
					});
					} // End of RevInitScript
				var once_revslider21 = false;
				if (document.readyState === "loading") {document.addEventListener('readystatechange',function() { if((document.readyState === "interactive" || document.readyState === "complete") && !once_revslider21 ) { once_revslider21 = true; revinit_revslider21();}});} else {once_revslider21 = true; revinit_revslider21();}
				</script>
			</rs-module-wrap>
			<!-- END REVOLUTION SLIDER -->
</div></div></div></div><div id="pg-5-1"  class="panel-grid panel-has-style" ><div class="panel-row-style panel-row-style-for-5-1" ><div id="pgc-5-1-0"  class="panel-grid-cell panel-grid-cell-empty" ></div><div id="pgc-5-1-1"  class="panel-grid-cell panel-grid-cell-mobile-last" ><div id="panel-5-1-1-0" class="widget_text so-panel widget widget_custom_html panel-first-child panel-last-child" data-index="1" ><div class="widget_text centcon panel-widget-style panel-widget-style-for-5-1-1-0" ><div class="textwidget custom-html-widget"><div class="maintitlecd text-center"><h1 class="custtl">Holy week schedule for Immaculate Heart of Mary￼ Catholic Church</h1></div>

Holy week schedule for Immaculate Heart of Mary￼ Catholic Church

Palm Sunday￼-Private Mass-8am
(Distribution of Palms Saturday April 4th from 5 p.m. to 7 p.m. and Sunday April 5th from 9 a.m. until 12 noon in the parking lot! This will be drive-thru only no need to get out of your vehicles! You are asked to bring your church offerings! )￼

Monday through Wednesday of holy week live streamed mass each day at 1 PM￼
Holy Thursday￼-Private mass 5 PM￼
Good Friday-Passion of the Lord done in private at 3 PM￼
Holy Saturday-Easter vigil celebrated in private at 7 PM￼￼
Easter Sunday live streamed mass at 1 PM￼

Here is the updated schedule of papal liturgical ceremonies for Holy Week and Easter released by the Vatican (times listed are local):
April 5, Palm Sunday, 11 a.m.
April 9, Holy Thursday, Mass of the Lord's Supper 6 p.m.
April 10, Good Friday, 6 p.m. liturgy of the Lord's passion.
April 10, Way of the Cross, 9 p.m., in front of St. Peter's Basilica.
April 11, Easter vigil Mass, 9 p.m.
April 12, Easter morning Mass, 11 a.m. followed by the pope's blessing "urbi et orbi" (to the city and the world).

<a href="https://www.facebook.com/ImmaculateHeartofMaryLafayetteLa/">PLEASE LIKE OUR FACEBOOK PAGE HERE FOR MORE UPDATES</a> 
</div></div></div></div><div id="pgc-5-1-2"  class="panel-grid-cell panel-grid-cell-empty" ></div></div></div><div id="pg-5-2"  class="panel-grid panel-no-style" ><div id="pgc-5-2-0"  class="panel-grid-cell" ><div id="panel-5-2-0-0" class="widget_text so-panel widget widget_custom_html panel-first-child panel-last-child" data-index="2" ><div class="widget_text centcon panel-widget-style panel-widget-style-for-5-2-0-0" ><div class="textwidget custom-html-widget"><div class="maintopleft">
	<div class="maintitlecd"><h2 class="custtl">Mass Schedule</h2></div>
<div class="weekly_bulletin">
	<a href="http://discovermass.com/church/immaculate-heart-of-mary-lafayette-la/">Weekly Bulletin</a>
</div>
</div>
</div></div></div></div><div id="pgc-5-2-1"  class="panel-grid-cell" ><div id="panel-5-2-1-0" class="widget_text so-panel widget widget_custom_html panel-first-child panel-last-child" data-index="3" ><div class="widget_text centcon panel-widget-style panel-widget-style-for-5-2-1-0" ><div class="textwidget custom-html-widget"><div class="maintopright">
<div class="">
<strong><i>MASS SCHEDULE</i></strong>
	
<div>Monday - Friday: 6:00am & 6:00pm
</div>
<div>Saturday: 6:00am & 4:00pm</div>

<div>Sunday: 6:00am, 9:00am & 11:00am</div>
	
	
	
	</div>
</div>

</div></div></div></div></div><div id="pg-5-3"  class="panel-grid panel-no-style" ><div id="pgc-5-3-0"  class="panel-grid-cell panel-grid-cell-empty" ></div><div id="pgc-5-3-1"  class="panel-grid-cell panel-grid-cell-mobile-last" ><div id="panel-5-3-1-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="4" ><div class="widget_text centcon panel-widget-style panel-widget-style-for-5-3-1-0" ><div class="textwidget custom-html-widget"><h3 class="custtl">
	HOLY WEEK MASS SCHEDULE
</h3>
<p class="custtl">
Holy Thursday, Thursday, April 1, 2021 - 7:00pm (No Washing of the Feet)<br>
Good Friday, Friday, April 2, 2021 - Stations of the Cross 12:00pm (Confession available during this time.)<br>
Good Friday, Friday, April 2, 2021 - Passion of the Lord Service 3:00pm (No Masses)<br>	
Easter Vigil, Saturday, April 3, 2021 - 8:00pm (No 6:00am Mass, no 4:00pm Mass)<br> 
Easter Sunday, April 4, 2021 - 6:00am, 9:00am & 11:00am<br>
</p>
<div class="hmtxt1">
	</div>

</div></div></div><div id="panel-5-3-1-1" class="widget_text so-panel widget widget_custom_html panel-last-child" data-index="5" ><div class="widget_text centcon panel-widget-style panel-widget-style-for-5-3-1-1" ><div class="textwidget custom-html-widget"><h2 class="custtl">
	Welcome to Immaculate Heart of Mary Catholic Church
</h2>
<div class="hmtxt1">
	Immaculate Heart of Mary Catholic Church, in keeping with the charism and tradition of the founder of the Society of the Divine Word, focuses on providing the Word and Eucharist to its congregation and all who visit. Emphasizing the Mission of the Universal Church, Evangelization and the Historical Culture of Immaculate Heart of Mary Parish, we welcome all of God's people to hear the Good News.  As a community of faithful stewards we continue to proclaim God's promise of new life, encourage people to experience it, and enable them to faithfully live it out in love for God and Neighbor.

</div>

</div></div></div></div><div id="pgc-5-3-2"  class="panel-grid-cell panel-grid-cell-empty" ></div></div><div id="pg-5-4"  class="panel-grid panel-has-style" ><div class="siteorigin-panels-stretch panel-row-style panel-row-style-for-5-4" data-stretch-type="full-stretched" ><div id="pgc-5-4-0"  class="panel-grid-cell" ><div id="panel-5-4-0-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="6" ><div id="mbdsplynn" class="widget_text panel-widget-style panel-widget-style-for-5-4-0-0" ><div class="textwidget custom-html-widget"></div></div></div><div id="panel-5-4-0-1" class="widget_text so-panel widget widget_custom_html" data-index="7" ><div id="mbdsplynn" class="widget_text panel-widget-style panel-widget-style-for-5-4-0-1" ><div class="textwidget custom-html-widget"></div></div></div><div id="panel-5-4-0-2" class="so-panel widget widget_tribe-events-list-widget tribe-events-list-widget panel-last-child" data-index="8" ><div class="hmsdrgt maincon panel-widget-style panel-widget-style-for-5-4-0-2" ><h3 class="widget-title">Upcoming Events</h3>	<p>There are no upcoming events at this time.</p>
</div></div></div><div id="pgc-5-4-1"  class="panel-grid-cell" ><div id="panel-5-4-1-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="9" ><div id="mbdsplynn" class="widget_text panel-widget-style panel-widget-style-for-5-4-1-0" ><div class="textwidget custom-html-widget"></div></div></div><div id="panel-5-4-1-1" class="widget_text so-panel widget widget_custom_html" data-index="10" ><div id="mbdsplynn" class="widget_text panel-widget-style panel-widget-style-for-5-4-1-1" ><div class="textwidget custom-html-widget"></div></div></div><div id="panel-5-4-1-2" class="widget_text so-panel widget widget_custom_html panel-last-child" data-index="11" ><div class="widget_text maincon panel-widget-style panel-widget-style-for-5-4-1-2" ><div class="textwidget custom-html-widget"><h2 class="custtl"><u>DEVOTIONS</u></h2>
<div class="sdivtxt1">Mother of Perpetual Help Novena</div>
<div>Tuesday 6:00 pm</div>

<div class="sdivtxt1">Rosa Mystica</div>
<div>Thursday  5:00 pm</div>

<div class="sdivtxt1">Confession</div>
<div>Saturday  3:15 pm-3:45 pm or by Appointment</div>

<div class="sdivtxt1">Holy Hour Adoration</div>
<div>Tuesday 5:00 pm - 6:00 pm</div>

<div class="sdivtxt1">Bible Study</div>
<div>Wednesday 6:30 pm</div></div></div></div></div><div id="pgc-5-4-2"  class="panel-grid-cell" ><div id="panel-5-4-2-0" class="widget_text so-panel widget widget_custom_html panel-first-child panel-last-child" data-index="12" ><div class="widget_text cntrd bxdhm panel-widget-style panel-widget-style-for-5-4-2-0" id="mainrightman" ><div class="textwidget custom-html-widget"><div class="home_church fullwid">
	<div class="home_church_img newlhlfcls1"><div style="text-align:center;"><img src="https://ihmchurchlafayette.com/wp-content/uploads/2019/10/Father-Augustine-Wall-SVD.png"> <div style="margin:20px 0px;"> Pastor: Fr. Augustine Wall, SVD</div></div></div>
<div class="home_church_text newlhlfcls">
<h2 class="custtl ndcls">Pastoral Staff</h2>
<div>Divine Word Missionaries</div>
<div>Pastor:  Fr. Augustine Wall, SVD</div>
<div>Assoc. Pastor:  Fr. Nick Hien Nguyen, SVD</div>
<div>In Residence:  Fr. Richard Kalinowski, SVD</div>
<div class="mar-5c">Permanent Deacon: Deacon Michael Morrison</div>
<div class="mar-5c">Parish Secretary: Jeannette Granger</div>
<div>Bookkeeper: </div>
		<div>Director of Religious Education:  Lana Pierre</div></div>
	</div></div></div></div></div></div></div><div id="pg-5-5"  class="panel-grid panel-no-style" ><div id="pgc-5-5-0"  class="panel-grid-cell panel-grid-cell-empty" ></div><div id="pgc-5-5-1"  class="panel-grid-cell panel-grid-cell-mobile-last" ><div id="panel-5-5-1-0" class="widget_text so-panel widget widget_custom_html panel-first-child panel-last-child" data-index="13" ><div class="widget_text centcon panel-widget-style panel-widget-style-for-5-5-1-0" ><div class="textwidget custom-html-widget"><h3 class="maincushead1">Get Involved</h3></div></div></div></div><div id="pgc-5-5-2"  class="panel-grid-cell panel-grid-cell-empty" ></div></div><div id="pg-5-6"  class="panel-grid panel-no-style" ><div id="pgc-5-6-0"  class="panel-grid-cell" ><div id="panel-5-6-0-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="14" ><div class="textwidget custom-html-widget"></div></div><div id="panel-5-6-0-1" class="widget_text so-panel widget widget_custom_html panel-last-child" data-index="15" ><div class="textwidget custom-html-widget"> <a href="https://ihmchurchlafayette.com/sacraments/" class="miancusc"><div class="hovereffect">
	 <img class="img-responsive" src="https://ihmchurchlafayette.com/wp-content/uploads/2020/04/Sacraments.png" alt="">
            <div class="overlay">
                
				<p>
					SACRAMENTS
				</p>
            </div>
	 </div></a>

</div></div></div><div id="pgc-5-6-1"  class="panel-grid-cell" ><div id="panel-5-6-1-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="16" ><div class="textwidget custom-html-widget"></div></div><div id="panel-5-6-1-1" class="widget_text so-panel widget widget_custom_html panel-last-child" data-index="17" ><div class="textwidget custom-html-widget"> <a href="https://ihmchurchlafayette.com/religious-education/" class="miancusc"><div class="hovereffect">
	 <img class="img-responsive" src="https://ihmchurchlafayette.com/wp-content/uploads/2019/06/Religious-Education.jpg" alt="Pastoral Staff">
            <div class="overlay">
                
				<p>
					RELIGIOUS EDUCATION
				</p>
            </div>
    </div></a>

</div></div></div></div><div id="pg-5-7"  class="panel-grid panel-no-style" ><div id="pgc-5-7-0"  class="panel-grid-cell" ><div id="panel-5-7-0-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="18" ><div class="textwidget custom-html-widget"></div></div><div id="panel-5-7-0-1" class="widget_text so-panel widget widget_custom_html panel-last-child" data-index="19" ><div class="textwidget custom-html-widget"> <a href="https://ihmchurchlafayette.com/ministries/" class="miancusc"><div class="hovereffect">
	 <img class="img-responsive" src="https://ihmchurchlafayette.com/wp-content/uploads/2019/06/Choir.jpg" alt="">
            <div class="overlay">
                
				<p>
					MINISTRIES
				</p>
            </div>
    </div></a>
</div></div></div><div id="pgc-5-7-1"  class="panel-grid-cell" ><div id="panel-5-7-1-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="20" ><div class="textwidget custom-html-widget"></div></div><div id="panel-5-7-1-1" class="widget_text so-panel widget widget_custom_html panel-last-child" data-index="21" ><div class="textwidget custom-html-widget"> <a href="https://ihmchurchlafayette.com/parish-services/" class="miancusc"><div class="hovereffect">
	 <img class="img-responsive" src="https://ihmchurchlafayette.com/wp-content/uploads/2019/06/Immaculate-Heart-of-Mary-1.jpg" alt="">
            <div class="overlay">
                
				<p>
					PARISH SERVICES
				</p>
            </div>
    </div></a>

</div></div></div></div><div id="pg-5-8"  class="panel-grid panel-has-style" ><div class="siteorigin-panels-stretch panel-row-style panel-row-style-for-5-8" data-stretch-type="full" ><div id="pgc-5-8-0"  class="panel-grid-cell" ><div id="panel-5-8-0-0" class="widget_text so-panel widget widget_custom_html panel-first-child panel-last-child" data-index="22" ><div class="widget_text  animated fadeInLeft delay1 duration1 eds-on-scroll panel-widget-style panel-widget-style-for-5-8-0-0" ><div class="textwidget custom-html-widget"><div class="maincodec">
<div>
	Interested in learning more about us 
	</div>
<div>
	or want to become a Parishioner?
	</div>
</div>
</div></div></div></div><div id="pgc-5-8-1"  class="panel-grid-cell" ><div id="panel-5-8-1-0" class="widget_text so-panel widget widget_custom_html panel-first-child panel-last-child" data-index="23" ><div class="widget_text  animated fadeInRight delay1 duration1 eds-on-scroll panel-widget-style panel-widget-style-for-5-8-1-0" ><div class="textwidget custom-html-widget"><div class="weekly_bulletin">
	<a href="https://ihmchurchlafayette.com/contact-ihm-catholic-church/">Contact Us</a>
</div></div></div></div></div></div></div><div id="pg-5-9"  class="panel-grid panel-has-style" ><div class="siteorigin-panels-stretch panel-row-style panel-row-style-for-5-9" id="optinhidn" data-stretch-type="full" ><div id="pgc-5-9-0"  class="panel-grid-cell" ><div id="panel-5-9-0-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="24" ><div class="widget_text csmanic panel-widget-style panel-widget-style-for-5-9-0-0" ><div class="textwidget custom-html-widget"></div></div></div><div id="panel-5-9-0-1" class="so-panel widget widget_text panel-last-child" data-index="25" >			<div class="textwidget"><!-- Widget Shortcode --><div id="custom_html-2" class="widget_text widget widget_custom_html widget-shortcode area-search_sidebar "><div class="textwidget custom-html-widget"><div class="section_app">
	<img src="https://ihmchurchlafayette.com/wp-content/uploads/2019/06/top-1.png">
	<div class="section_app_text">
		
	<b>Download myParish App</b><br>
on your smartphone or tablet
		</div>
	<a href="https://play.google.com/store/apps/details?id=com.michiganlabs.myparish" target="”_blank”" rel="noopener">
	<img src="https://ihmchurchlafayette.com/wp-content/uploads/2019/06/ply.png"></a>
	
	<a href="https://itunes.apple.com/us/app/myparish/id892066479?mt=8" target="”_blank”" rel="noopener"><img src="https://ihmchurchlafayette.com/wp-content/uploads/2019/06/apple.png"></a>
</div></div></div><!-- /Widget Shortcode -->
</div>
		</div></div><div id="pgc-5-9-1"  class="panel-grid-cell" ><div id="panel-5-9-1-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="26" ><div class="textwidget custom-html-widget"><h3 class="maincushead">STAY CONNECTED</h3></div></div><div id="panel-5-9-1-1" class="so-panel widget widget_ocean_mailchimp widget-oceanwp-mailchimp mailchimp-widget panel-last-child" data-index="27" ><div id="optinForm" class="panel-widget-style panel-widget-style-for-5-9-1-1" ><h3 class="widget-title">Newsletter Sign Up</h3>
            <div class="oceanwp-newsletter-form clr">

                <div class="oceanwp-newsletter-form-wrap">

                    
                        <div class="oceanwp-mail-text">Stay connected with emails and information from Immaculate Heart of Mary Catholic Church. Join Today!</div>

                    
                    <form action="" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>

                        <div class="email-wrap elem-wrap">
                            <input aria-label="Enter your email address to subscribe" type="email" placeholder="Your Email" onfocus="if (this.value == this.defaultValue)this.value = '';" onblur="if (this.value == '')this.value = this.defaultValue;" name="EMAIL" class="required email">

                                                            <button aria-label="Submit email address" type="submit" value="" name="subscribe" class="button">
                                    I&#039;m In                                </button>
                                                    </div>
                        <span class="email-err err-msg req" style="display:none;">Email is required</span>
                        <span class="email-err err-msg not-valid" style="display:none;">Email is not valid</span>

                        
                        <div class="success res-msg" style="display:none;">Thanks for your subscription.</div>
                        <div class="failed  res-msg" style="display:none;">Failed to subscribe, please contact admin.</div>
                    </form>

                </div><!--.oceanwp-newsletter-form-wrap-->

            </div><!-- .oceanwp-newsletter-form -->

            </div></div></div><div id="pgc-5-9-2"  class="panel-grid-cell" ><div id="panel-5-9-2-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="28" ><div class="widget_text csmanic panel-widget-style panel-widget-style-for-5-9-2-0" ><div class="textwidget custom-html-widget"></div></div></div><div id="panel-5-9-2-1" class="widget_text so-panel widget widget_custom_html panel-last-child" data-index="29" ><div class="widget_text panel-widget-style panel-widget-style-for-5-9-2-1" ><div class="textwidget custom-html-widget"><!-- Widget Shortcode --><div id="ocean_facebook-2" class="widget widget_facebook_likebox widget-shortcode area-sidebar-2 ">
			<iframe src="https://www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FImmaculate-Heart-of-Mary-Catholic-Church-1209420412553260&#038;width=300&#038;height=250&#038;colorscheme=light&#038;show_faces=true&#038;stream=false&#038;show_border=true&#038;header=false&#038;force_wall=false" scrolling="no" frameborder="0" style="border: none; overflow: hidden; width: 300px;  height: 250px; background: #fff"></iframe></div><!-- /Widget Shortcode --></div></div></div></div></div></div><div id="pg-5-10"  class="panel-grid panel-has-style" ><div class="siteorigin-panels-stretch panel-row-style panel-row-style-for-5-10" id="optin" data-stretch-type="full" ><div id="pgc-5-10-0"  class="panel-grid-cell" ><div id="panel-5-10-0-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="30" ><div class="widget_text csmanic panel-widget-style panel-widget-style-for-5-10-0-0" ><div class="textwidget custom-html-widget"></div></div></div><div id="panel-5-10-0-1" class="so-panel widget widget_text panel-last-child" data-index="31" >			<div class="textwidget"><!-- Widget Shortcode --><div id="custom_html-2" class="widget_text widget widget_custom_html widget-shortcode area-search_sidebar "><div class="textwidget custom-html-widget"><div class="section_app">
	<img src="https://ihmchurchlafayette.com/wp-content/uploads/2019/06/top-1.png">
	<div class="section_app_text">
		
	<b>Download myParish App</b><br>
on your smartphone or tablet
		</div>
	<a href="https://play.google.com/store/apps/details?id=com.michiganlabs.myparish" target="”_blank”" rel="noopener">
	<img src="https://ihmchurchlafayette.com/wp-content/uploads/2019/06/ply.png"></a>
	
	<a href="https://itunes.apple.com/us/app/myparish/id892066479?mt=8" target="”_blank”" rel="noopener"><img src="https://ihmchurchlafayette.com/wp-content/uploads/2019/06/apple.png"></a>
</div></div></div><!-- /Widget Shortcode -->
</div>
		</div></div><div id="pgc-5-10-1"  class="panel-grid-cell" ><div id="panel-5-10-1-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="32" ><div class="textwidget custom-html-widget"><h3 class="maincushead">STAY CONNECTED</h3></div></div><div id="panel-5-10-1-1" class="so-panel widget widget_ocean_mailchimp widget-oceanwp-mailchimp mailchimp-widget panel-last-child" data-index="33" ><div id="optinForm" class="panel-widget-style panel-widget-style-for-5-10-1-1" ><h3 class="widget-title">Newsletter Sign Up</h3>
            <div class="oceanwp-newsletter-form clr">

                <div class="oceanwp-newsletter-form-wrap">

                    
                        <div class="oceanwp-mail-text">Stay connected with emails and information from Immaculate Heart of Mary Catholic Church. Join Today!</div>

                    
                    <form action="" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>

                        <div class="email-wrap elem-wrap">
                            <input aria-label="Enter your email address to subscribe" type="email" placeholder="Your Email" onfocus="if (this.value == this.defaultValue)this.value = '';" onblur="if (this.value == '')this.value = this.defaultValue;" name="EMAIL" class="required email">

                                                            <button aria-label="Submit email address" type="submit" value="" name="subscribe" class="button">
                                    I&#039;m In                                </button>
                                                    </div>
                        <span class="email-err err-msg req" style="display:none;">Email is required</span>
                        <span class="email-err err-msg not-valid" style="display:none;">Email is not valid</span>

                        
                        <div class="success res-msg" style="display:none;">Thanks for your subscription.</div>
                        <div class="failed  res-msg" style="display:none;">Failed to subscribe, please contact admin.</div>
                    </form>

                </div><!--.oceanwp-newsletter-form-wrap-->

            </div><!-- .oceanwp-newsletter-form -->

            </div></div></div><div id="pgc-5-10-2"  class="panel-grid-cell" ><div id="panel-5-10-2-0" class="widget_text so-panel widget widget_custom_html panel-first-child" data-index="34" ><div class="widget_text csmanic panel-widget-style panel-widget-style-for-5-10-2-0" ><div class="textwidget custom-html-widget"></div></div></div><div id="panel-5-10-2-1" class="widget_text so-panel widget widget_custom_html panel-last-child" data-index="35" ><div class="widget_text panel-widget-style panel-widget-style-for-5-10-2-1" ><div class="textwidget custom-html-widget"><!-- Widget Shortcode --><div id="ocean_facebook-2" class="widget widget_facebook_likebox widget-shortcode area-sidebar-2 ">
			<iframe src="https://www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FImmaculate-Heart-of-Mary-Catholic-Church-1209420412553260&#038;width=300&#038;height=250&#038;colorscheme=light&#038;show_faces=true&#038;stream=false&#038;show_border=true&#038;header=false&#038;force_wall=false" scrolling="no" frameborder="0" style="border: none; overflow: hidden; width: 300px;  height: 250px; background: #fff"></iframe></div><!-- /Widget Shortcode --></div></div></div></div></div></div><div id="pg-5-11"  class="panel-grid panel-has-style" ><div class="siteorigin-panels-stretch panel-row-style panel-row-style-for-5-11" data-stretch-type="full-stretched" ><div id="pgc-5-11-0"  class="panel-grid-cell" ><div id="panel-5-11-0-0" class="widget_text so-panel widget widget_custom_html panel-first-child panel-last-child" data-index="36" ><div class="textwidget custom-html-widget"><iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d3447.388399874949!2d-92.00440448491858!3d30.22599871692807!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x86249ca35fa1850b%3A0x7320ef20fbaf872d!2sImmaculate+Heart+of+Mary!5e0!3m2!1sen!2sin!4v1559742078081!5m2!1sen!2sin" width="100%" height="400" frameborder="0" style="border:0" allowfullscreen></iframe></div></div></div></div></div></div>	</div>
</article>
				
			</div><!-- #content -->

			
		</div><!-- #primary -->

		
	</div><!-- #content-wrap -->

	

        </main><!-- #main -->

        
        
        
            
<footer id="footer" class="site-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter">

    
    <div id="footer-inner" class="clr">

        

<div id="footer-widgets" class="oceanwp-row clr">

	
	<div class="footer-widgets-inner container">

        			<div class="footer-box  span_1_of_4   col col-1">
				<div id="ocean_custom_menu-3" class="footer-widget widget-oceanwp-custom-menu custom-menu-widget clr"><style type="text/css">.ocean_custom_menu-3 > ul > li > a, .custom-menu-widget .ocean_custom_menu-3 .dropdown-menu .sub-menu li a.menu-link{color:#ffffff;}.custom-menu-widget .ocean_custom_menu-3.oceanwp-custom-menu > ul.click-menu .open-this{color:#ffffff;}.ocean_custom_menu-3 > ul > li > a:hover, .custom-menu-widget .ocean_custom_menu-3 .dropdown-menu .sub-menu li a.menu-link:hover{color:#cfad42;}.custom-menu-widget .ocean_custom_menu-3.oceanwp-custom-menu > ul.click-menu .open-this:hover{color:#cfad42;}</style><h4 class="widget-title">Quick Links</h4><div class="oceanwp-custom-menu clr ocean_custom_menu-3 left dropdown-hover"><ul id="menu-quick-links" class="dropdown-menu sf-menu"><li  id="menu-item-914" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-914"><a href="https://ihmchurchlafayette.com/ministries/" class="menu-link">MINISTRIES</a></li>
<li  id="menu-item-915" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-915"><a href="https://ihmchurchlafayette.com/sacraments/" class="menu-link">SACRAMENTS</a></li>
<li  id="menu-item-918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-918"><a href="https://ihmchurchlafayette.com/parish-services/" class="menu-link">PARISH SERVICES</a></li>
<li  id="menu-item-925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-925"><a href="https://ihmchurchlafayette.com/events" class="menu-link">CALENDAR</a></li>
<li  id="menu-item-926" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-926"><a href="https://ihmchurchlafayette.com/contact-ihm-catholic-church/" class="menu-link">CONTACT</a></li>
</ul></div></div>			</div><!-- .footer-one-box -->

							<div class="footer-box span_1_of_2   col col-2">
					<div id="text-3" class="footer-widget widget_text clr">			<div class="textwidget"><div class="footer2">818 12th Street | P.O. Box 2398 | Lafayette, LA 70502<br />
Phone <a href="tel:(337) 235-4618">(337) 235-4618</a> Fax (337) 235-4775<br />
<a href="https://ihmchurchlafayette.com/contact-ihm-catholic-church/">Contact Us</a></div>
<div class="social-icons">
<div class="icon fa-icon">
<a href="https://www.facebook.com/Immaculate-Heart-of-Mary-Catholic-Church-1209420412553260" target="_blank" rel="noopener"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon img">
<a href="https://myparishapp.com" target="_blank" rel="noopener"><img src="https://ihmchurchlafayette.com/wp-content/uploads/2019/06/myParish_logo_.png"></a>
</div>
</div>
</div>
		</div>				</div><!-- .footer-one-box -->
						
							<div class="footer-box span_1_of_4   col col-3 ">
					<div id="text-4" class="footer-widget widget_text clr"><h4 class="widget-title">CHURCH OFFICE HOURS</h4>			<div class="textwidget"><div class="footer3"><b>Monday &#8211; Thursday</b><br />
8:30 am &#8211; 12 noon<br />
1:00 pm &#8211; 4:30 pm<br />
<b>Friday</b><br />
8:30 am &#8211; 12 noon</div>
</div>
		</div>				</div><!-- .footer-one-box -->
			
			
		
	</div><!-- .container -->

	
</div><!-- #footer-widgets -->



<div id="footer-bottom" class="clr no-footer-nav">

	
	<div id="footer-bottom-inner" class="container clr">

		
		
			<div id="copyright" class="clr" role="contentinfo">
				Copyright &copy; 2021 - Immaculate Heart of Mary Catholic Church			</div><!-- #copyright -->

		
	</div><!-- #footer-bottom-inner -->

	
</div><!-- #footer-bottom -->

        
    </div><!-- #footer-inner -->

    
</footer><!-- #footer -->            
        
                        
    </div><!-- #wrap -->

    
</div><!-- #outer-wrap -->
 <script>jQuery('.mainchng input[type="checkbox"]').attr('disabled', true);</script>
 


<a id="scroll-top" class="scroll-top-right" href="#"><span class="fa fa-angle-up"></span></a>



<div id="mobile-fullscreen" class="clr">

	<div id="mobile-fullscreen-inner" class="clr">

		<a href="#" class="close">
			<div class="close-icon-wrap">
				<div class="close-icon-inner"></div>
			</div>
		</a>

		<nav class="clr" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">

			<ul id="menu-main-menu-1" class="fs-dropdown-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-991"><a>ABOUT</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14"><a href="https://ihmchurchlafayette.com/history/">HISTORY</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-580"><a href="https://ihmchurchlafayette.com/masses/">MASS SCHEDULE</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-592"><a href="https://ihmchurchlafayette.com/pastoral-council-members/">PASTORAL COUNCIL MEMBERS</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-15"><a href="https://ihmchurchlafayette.com/ministries/">MINISTRIES</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1237"><a href="https://ihmchurchlafayette.com/worship-ministries/">WORSHIP MINISTRIES</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1239"><a href="https://ihmchurchlafayette.com/social-fellowship-ministries/">SOCIAL FELLOWSHIP MINISTRIES</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1238"><a href="https://ihmchurchlafayette.com/fraternal-organizations-ministries/">FRATERNAL ORGANIZATIONS/MINISTRIES</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-693"><a href="https://ihmchurchlafayette.com/ministry-organization-leaders/">MINISTRY &#038; ORGANIZATION LEADERS</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17"><a href="https://ihmchurchlafayette.com/sacraments/">SACRAMENTS</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16"><a href="https://ihmchurchlafayette.com/religious-education/">RELIGIOUS EDUCATION</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18"><a href="https://ihmchurchlafayette.com/parish-services/">PARISH SERVICES</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1042"><a href="https://ihmchurchlafayette.com/mass-intentions/">MASS INTENTIONS</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1041"><a href="https://ihmchurchlafayette.com/parishioner-registration/">PARISHIONER REGISTRATION</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1038"><a href="https://ihmchurchlafayette.com/burial-planning/">BURIAL PLANNING</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1037"><a href="https://ihmchurchlafayette.com/i-am-program/">&#8220;I AM&#8221; PROGRAM</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-548"><a href="https://ihmchurchlafayette.com/rental-request/">RENTAL REQUEST</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1046"><a href="https://ihmchurchlafayette.com/credit-union-2/">CREDIT UNION</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1039"><a href="https://ihmchurchlafayette.com/certificate-requests/">CERTIFICATE REQUESTS</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1040"><a href="https://ihmchurchlafayette.com/offertory-envelopes/">OFFERTORY ENVELOPES</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20"><a href="https://ihmchurchlafayette.com/link/">LINKS OF INTEREST</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19"><a href="https://ihmchurchlafayette.com/events/">CALENDAR</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1450"><a href="https://ihmchurchlafayette.com/gallery/">Gallery</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-677"><a href="https://ihmchurchlafayette.com/contact-ihm-catholic-church/">CONTACT</a></li>
<li class="donate_btn menu-item menu-item-type-custom menu-item-object-custom menu-item-455"><a href="https://ihmchurchlafayette.com/donate/">GIVE</a></li>
</ul>
<div id="mobile-search" class="clr">
	<form method="get" action="https://ihmchurchlafayette.com/" class="header-searchform">
		<input type="search" name="s" value="" autocomplete="off" />
					<label>Type your search<span><i></i><i></i><i></i></span></label>
					</form>
</div>
		</nav>

	</div>

</div>
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<div id="pum-1379" class="pum pum-overlay pum-theme-1375 pum-theme-enterprise-blue popmake-overlay pum-click-to-close auto_open click_open" data-popmake="{&quot;id&quot;:1379,&quot;slug&quot;:&quot;notice&quot;,&quot;theme_id&quot;:1375,&quot;cookies&quot;:[],&quot;triggers&quot;:[{&quot;type&quot;:&quot;auto_open&quot;,&quot;settings&quot;:{&quot;cookie_name&quot;:[&quot;pum-1379&quot;],&quot;delay&quot;:&quot;500&quot;}},{&quot;type&quot;:&quot;click_open&quot;,&quot;settings&quot;:{&quot;extra_selectors&quot;:&quot;&quot;,&quot;cookie_name&quot;:null}}],&quot;mobile_disabled&quot;:null,&quot;tablet_disabled&quot;:null,&quot;meta&quot;:{&quot;display&quot;:{&quot;stackable&quot;:false,&quot;overlay_disabled&quot;:false,&quot;scrollable_content&quot;:false,&quot;disable_reposition&quot;:false,&quot;size&quot;:&quot;small&quot;,&quot;responsive_min_width&quot;:&quot;0%&quot;,&quot;responsive_min_width_unit&quot;:false,&quot;responsive_max_width&quot;:&quot;100%&quot;,&quot;responsive_max_width_unit&quot;:false,&quot;custom_width&quot;:&quot;640px&quot;,&quot;custom_width_unit&quot;:false,&quot;custom_height&quot;:&quot;380px&quot;,&quot;custom_height_unit&quot;:false,&quot;custom_height_auto&quot;:false,&quot;location&quot;:&quot;center top&quot;,&quot;position_from_trigger&quot;:false,&quot;position_top&quot;:&quot;100&quot;,&quot;position_left&quot;:&quot;0&quot;,&quot;position_bottom&quot;:&quot;0&quot;,&quot;position_right&quot;:&quot;0&quot;,&quot;position_fixed&quot;:false,&quot;animation_type&quot;:&quot;fade&quot;,&quot;animation_speed&quot;:&quot;350&quot;,&quot;animation_origin&quot;:&quot;center top&quot;,&quot;overlay_zindex&quot;:false,&quot;zindex&quot;:&quot;1999999999&quot;},&quot;close&quot;:{&quot;text&quot;:&quot;&quot;,&quot;button_delay&quot;:&quot;0&quot;,&quot;overlay_click&quot;:&quot;1&quot;,&quot;esc_press&quot;:&quot;1&quot;,&quot;f4_press&quot;:&quot;1&quot;},&quot;click_open&quot;:[]}}" role="dialog" aria-hidden="true" >

	<div id="popmake-1379" class="pum-container popmake theme-1375 pum-responsive pum-responsive-small responsive size-small">

				

				

		

				<div class="pum-content popmake-content" tabindex="0">
			<h3>UPDATE</h3>
<hr />
<div style="color: #333; font-family: sans-serif; font-size: 18px;">
<p>Hello Everyone,</p>
<p>Mass Times<br />
Monday &#8211; Friday: 6:00am &amp; 6:00pm<br />
Saturday: 6:00am &amp; 4:00pm<br />
Sunday: 6:00am, 9:00am &amp; 11:00am</p>
<p>Please enter through the front of the church and follow the directions of the Ushers.<br />
Please wear a mask.<br />
Seating is every other pew ushers will help ensure social distancing.</p>
<p>Please check on your elderly family members and neighbors. Take every precaution and heed every warning issued by local, state and federal officials. Stay safe!</p>
<p><b>Thank you</b></p>
</div>
		</div>


				

				            <button type="button" class="pum-close popmake-close" aria-label="Close">
			×            </button>
		
	</div>

</div>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><link href="https://fonts.googleapis.com/css?family=Open+Sans:300%7CRoboto:400" rel="stylesheet" property="stylesheet" media="all" type="text/css" >

		<script type="text/javascript">
		if(typeof revslider_showDoubleJqueryError === "undefined") {
			function revslider_showDoubleJqueryError(sliderID) {
				var err = "<div class='rs_error_message_box'>";
				err += "<div class='rs_error_message_oops'>Oops...</div>";
				err += "<div class='rs_error_message_content'>";
				err += "You have some jquery.js library include that comes after the Slider Revolution files js inclusion.<br>";
				err += "To fix this, you can:<br>&nbsp;&nbsp;&nbsp; 1. Set 'Module General Options' -> 'Advanced' -> 'jQuery & OutPut Filters' -> 'Put JS to Body' to on";
				err += "<br>&nbsp;&nbsp;&nbsp; 2. Find the double jQuery.js inclusion and remove it";
				err += "</div>";
			err += "</div>";
				var slider = document.getElementById(sliderID); slider.innerHTML = err; slider.style.display = "block";
			}
		}
		</script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://ihmchurchlafayette.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://ihmchurchlafayette.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://ihmchurchlafayette.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://ihmchurchlafayette.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://ihmchurchlafayette.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://ihmchurchlafayette.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://ihmchurchlafayette.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' );
</script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/ihmchurchlafayette.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.4.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/themes/oceanwp/assets/js/third/magnific-popup.min.js?ver=1.6.7.1557958258' id='magnific-popup-js'></script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/themes/oceanwp/assets/js/third/lightbox.min.js?ver=1.6.7.1557958258' id='oceanwp-lightbox-js'></script>
<script type='text/javascript' id='oceanwp-main-js-extra'>
/* <![CDATA[ */
var oceanwpLocalize = {"isRTL":"","menuSearchStyle":"disabled","sidrSource":null,"sidrDisplace":"1","sidrSide":"left","sidrDropdownTarget":"link","verticalHeaderTarget":"link","customSelects":".woocommerce-ordering .orderby, #dropdown_product_cat, .widget_categories select, .widget_archive select, .single-product .variations_form .variations select","ajax_url":"https:\/\/ihmchurchlafayette.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/themes/oceanwp/assets/js/main.min.js?ver=1.6.7.1557958258' id='oceanwp-main-js'></script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/plugins/ocean-extra/includes/widgets/js/mailchimp.min.js?ver=5.7.2' id='oe-mailchimp-script-js'></script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' id='popup-maker-site-js-extra'>
/* <![CDATA[ */
var pum_vars = {"version":"1.16.2","pm_dir_url":"https:\/\/ihmchurchlafayette.com\/wp-content\/plugins\/popup-maker\/","ajaxurl":"https:\/\/ihmchurchlafayette.com\/wp-admin\/admin-ajax.php","restapi":"https:\/\/ihmchurchlafayette.com\/wp-json\/pum\/v1","rest_nonce":null,"default_theme":"1373","debug_mode":"","disable_tracking":"","home_url":"\/","message_position":"top","core_sub_forms_enabled":"1","popups":[],"analytics_route":"analytics","analytics_api":"https:\/\/ihmchurchlafayette.com\/wp-json\/pum\/v1"};
var pum_sub_vars = {"ajaxurl":"https:\/\/ihmchurchlafayette.com\/wp-admin\/admin-ajax.php","message_position":"top"};
var pum_popups = {"pum-1379":{"triggers":[{"type":"auto_open","settings":{"cookie_name":["pum-1379"],"delay":"500"}}],"cookies":[],"disable_on_mobile":false,"disable_on_tablet":false,"atc_promotion":null,"explain":null,"type_section":null,"theme_id":"1375","size":"small","responsive_min_width":"0%","responsive_max_width":"100%","custom_width":"640px","custom_height_auto":false,"custom_height":"380px","scrollable_content":false,"animation_type":"fade","animation_speed":"350","animation_origin":"center top","open_sound":"none","custom_sound":"","location":"center top","position_top":"100","position_bottom":"0","position_left":"0","position_right":"0","position_from_trigger":false,"position_fixed":false,"overlay_disabled":false,"stackable":false,"disable_reposition":false,"zindex":"1999999999","close_button_delay":"0","fi_promotion":null,"close_on_form_submission":false,"close_on_form_submission_delay":"0","close_on_overlay_click":true,"close_on_esc_press":true,"close_on_f4_press":true,"disable_form_reopen":false,"disable_accessibility":false,"theme_slug":"enterprise-blue","id":1379,"slug":"notice"}};
/* ]]> */
</script>
<script type='text/javascript' src='//ihmchurchlafayette.com/wp-content/uploads/pum/pum-site-scripts.js?defer&#038;generated=1626051465&#038;ver=1.16.2' id='popup-maker-site-js'></script>
<script type='text/javascript' id='wpcf7cf-scripts-js-extra'>
/* <![CDATA[ */
var wpcf7cf_global_settings = {"ajaxurl":"https:\/\/ihmchurchlafayette.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/plugins/cf7-conditional-fields/js/scripts.js?ver=2.0.4' id='wpcf7cf-scripts-js'></script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/themes/oceanwp/assets/js/third/html5.min.js?ver=1.6.7.1557958258' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' id='siteorigin-panels-front-styles-js-extra'>
/* <![CDATA[ */
var panelsStyles = {"fullContainer":"body"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ihmchurchlafayette.com/wp-content/plugins/siteorigin-panels/js/styling.min.js?ver=2.13.2' id='siteorigin-panels-front-styles-js'></script>
<script type="text/javascript">document.body.className = document.body.className.replace("siteorigin-panels-before-js","");</script><script>


jQuery('input:radio[name="check-same-add"]').change(
    function(){
        if (jQuery(this).is(':checked') && jQuery(this).val() == 'Yes') {

        var fathe_addr = jQuery("input[name='father-address']").val();
        var fathe_zip = jQuery("input[name='father-zip']").val();
        jQuery("input[name='mother-address']").val(fathe_addr);
        jQuery("input[name='mother-zip']").val(fathe_zip);

    }else{

    	jQuery("input[name='mother-address']").val('');
		jQuery("input[name='mother-zip']").val('');

	}
}); 
</script>
</body>
</html>